Glitch With iPhone 4.0 Beta? Developers Struggle To Load OS on 3GS with error 13

After much fanfare, the iPhone OS 4 beta gets out to developers ready to test out the new OS on their iPhone. Unfortunately, it seems that there are some problems with the firmware or the server at the back end.

Forums are filled with posts describing the errors they faced with new OS. One such developer express disgrunt that his multiple attempts to update to 4.0 weren’t successful. The itunes software always return error code 13 (which usually indicates bad USB cable or USB ports).

While some had success updating the firmware using the Mac, the PC users are left in the dark with strange upgrading issues.

Are you facing the same problems ? Post your comments here.


11 Comments

  1. Brad July 9, 2010 8:47 am  Reply

    USB connection is fine for me. Not a problem. Mail doesn’t always refresh and the facebook ap isn’t working right. When I review pictures from the camera, smaller pictures from my film roll show up and it freezes. Who tests this stuff before sending it out? Probably going to revert my 3Gs back to 3.1.2. Apple shouldn’t have rushed the launch of the new iPhone 4 and tried perfecting the OS first. But then they wouldn’t have sold as many 4’s since the features of the 4 and the OS 4.0 are so similar. As the saying goes, build and ask for forgiveness later.

  2. Hjkjohn May 2, 2010 11:27 am  Reply

    Apple I racist to us pc users they don’t give a shit about is I always get the 13 error when trying to update. I don’t know one person with a mac

    • bluetooth May 3, 2010 11:13 am  Reply

      You can use vmware and run mac os to install it

  3. Clive April 14, 2010 5:37 pm  Reply

    Steven, remember this is a beta build. Not everything is going to work properly. You shouldn’t load it on a phone that is essential. If you can’t live with the issues you can downgrade to 3.1.3 again until a later build comes out.

  4. steven April 14, 2010 8:15 am  Reply

    i have a ton of problems with it, usbs dont connect to it.. it connects and disconnects continuously until i unplug it, the zoom in the camera only takes black and white pictures, and in mail and other apps that require network it keeps telling me i have network problem .. i ususally have to reboot the app, i need 3.1.3 back or im throwing this thing in a lake

    • bluetooth April 14, 2010 3:15 pm  Reply

      Gosh I can confirm that gmaps is messed up too

  5. Nayte wilson April 12, 2010 7:36 am  Reply

    I used a pc, and yes you can revert To os 3.1.2 from 4.0 there are alrady guides telling you how to do so. Just google it. Googles your best friend.

  6. Nayte Wilson April 11, 2010 8:50 am  Reply

    Yeah… I’m trying to update on Windows 7 Pro, and I’ve had no luck I tried recovery mode, and DFU mode with no prevail. So, I’m assuming Apple doesn’t want Window users to update since the SDK is only on Macs, but this makes no sense since all earlier versions of the OS worked fine on Windows, so I’m not sure it might be a glitch or it might not be.

    Nayte Wilson

  7. Mikkel a April 10, 2010 9:00 pm  Reply

    Hey.

    I have a couple of iphone 3gs, and some windows machines, i have struggled,a long time now, getting the error 13. i have tried, all sorts of things, but nothing works. geuss i need a mac then ?

    Please reply if anyone finds an solution.

  8. Matthew McDonough April 10, 2010 2:36 pm  Reply

    Intermittent loss of voice control, places poping up in photos and SMS sounds random. Using the old iStat app shows the drain on my resources (47ish MB) tied up for background Apps. The compass tends to crash and the zoom for the camera does not allow the touch to focus. Other than that it’s good Beta for daily use.

    • bluetooth April 11, 2010 9:17 am  Reply

      Did you use a MAC to update or a PC
      are you able to revert back to 3.1.3 if necessary

Leave a comment

Your email address will not be published. Required fields are marked *